For all account questions and concerns, contact Customer Support.

Follow important game updates on Twitter @Pirate101 and @KI_Alerts, and Facebook!

Swashbucklers, just want a fun run

AuthorMessage
Bosun
Dec 24, 2009
394
So, this is my 8th run to defeat Kane, and man was it very inconvenient. I promise I won't write a board for EVERY run I do, but this time, like last time, was exceptional.

So I went to Team Up! to find a group since nobody was near the sigil. I went into the Machine with myself and another Swashbuckler, named Layne Leveer. So we did a duo of the entire dungeon. Well... almost the entire dungeon. We were in the fight with Kane, and it was down to Kane, a Queen, and a Rooke. We were close to ending the match, when suddenly, I disconnected. I felt really bad that I had disconnected and I quickly logged back on.
When I logged back on, I was back in the dungeon with Layne, but we were in the room with the first two fights. When I myself logged back on, there were two other people who were already starting the first fight. So we joined them in the fight, and we explained our situation to them. As it turned out, one person was in the same situation; he was in the dungeon when he disconnected and logged on in our dungeon. The other guy claims to have been in Avery's Court when he was sent to the Machine after he was also disconnected I assume. So this time with feeling, we made it through the first fight. We got into the second fight, and with some difficulty, we managed to get through the second fight. When we ended the fight, I volunteered to wait in the dungeon while everybody else went to clear out their banks. When everybody got back, we encountered a strange problem. We couldn't ride Kane's elevator to the final battle. We tried and tried but we didn't get the prompt. Then it occurs to me; I don't have the quest in my list of quests. Somehow, all of us had entered the dungeon without getting the quest that allows us to progress through the dungeon.
So, a few of us saw we had the button that allows us to return to the dungeon. It is labelled "Return to the Machine". So three of us clicked on it. We appeared back at the room with the elevator before the room with the fights. After some deliberation, we decided to just go outside and restart the dungeon. The guy who wasn't with us was waiting outside the dungeon. The guy who came with us had to leave unfortunately, so it was the three of us waiting outside the dungeon for somebody.
I went to Skull Island to revive my companions and get my potions back. When I came back, I started clearing my backpack. As I'm clearing, Miss Esperanza once again comes and saves the day at the most convenient time. Now that we have our group of four, we go back in, and we finally clear the dungeon, after a rather glitchy sequence of El Toro constantly attacking an empty space as treasure chests appear at the end of the second fight.

Oh, and this time, there were NO marines turned into Queens (Thankfully).

Fearless Dolan Grant lvl 70

Lieutenant
Sep 21, 2014
177
I've experienced a situation alike this before, although I went into the sigil for a boss fight on my own and when I got in there, 2 other guys I never had met before were in there, one came after me) one was already fighting boss. dude. was weird