Two pet bugs

AuthorMessage
Commodore
May 31, 2009
800
When I tried to place my Corrupted Imperial Lion in my house, he did not show up on the item menu. He was not training, and not equipped. It seems like he just never got the 'Hey, you can be a housing item!' message.

Also, I have noticed that when there are multiple pirates in a house all of the pets stop moving. They still have their idle animations, but they don't walk/swim/fly around. As soon as the other pirate(s) leave, they begin moving again.

Petty Officer
Mar 04, 2012
52
My Corrupted Foo Lion won't show up either in my housing items. Please fix this bug somebody.

Pirate Overlord
Mar 16, 2012
5736
Same here whenever I've tried to place that Foo Lion, he doesn't show up! Can't put him in the attic, either!

Petty Officer
May 21, 2008
60
These and some other furniture items are missing type tag to them and so they only show up when you click "All" button with infinity symbol on it.

Commodore
May 31, 2009
800
Jojimbo101 on Sep 18, 2014 wrote:
These and some other furniture items are missing type tag to them and so they only show up when you click "All" button with infinity symbol on it.
Even with all items selected, the Corrupted Lion still does not show up. It may be missing the furniture tag entirely. I sincerely hope this is a bug because I don't have enough bank space to put pets in, I can't place the lion in my attic (due to the bug of it not being a housing item), and I want to keep the pet on my Swashbuckler. I can keep the lion in my backpack now, but when I no longer need to level it up I'd like to be able to place the pet in my house so I can pick it up in the future if I wish to morph it.