Troy - bug?

AuthorMessage
Petty Officer
Jan 30, 2013
51
So a friend of mine and I were entering the first half of Troy. We defeated the snakes out front, then entered doors as instructed. I knew something was off, when Gracie never spotted the gears above us, but instead, we fought the snakes there (which is what you're supposed to do AFTER you locate gears). Well, this threw us all out of sync and off track. After we defeated the snakes, we then spotted the gears, then our arrow was telling us to fight the snakes...the snakes we'd already beaten, the snakes that weren't there.
We could not advance, we tried leaving one at a time and porting back in, we tried everything.
The only way we could go on, was to start all over.
It was no big deal, it happened early in Troy, but may be something worth looking into.

Lieutenant
Oct 21, 2012
101
It happened to me too! Just now. I defeated the ophidians 1, 2, wave, then opened the gates, and I had to defeat ophidian warriors. Yeah, I lost . But when I got back in troy to try again from where I ended, the warriors weren't there. The warriors had a golden armor. My arrow was pointing to the spot where they had to be.
I checked my quest map and- get this - there was a quest '' Hello, walls'' and a '' Mouse trap''. What should I do? I don't want to start all of troy all over again, I had enough of those snakes!
KI can you fix this? Please?