Ship Powers Askew

AuthorMessage
Ensign
Feb 16, 2010
25
I had noticed a few days ago that my horn (the great serpent) was not appearing when used on my Aquillan frigate, and was not showing that it was doing any damage. Last night nautical farming with friends, a friend's galleon also had the same problem. We also realized that a number of the ships powers, both ours and the enemy ships had the animations occuring sidewise. Among those noted were the enemy ship's accuracy boost, our hex attack, the sirens attack, and the enemy ship healing. We were in Westminster skyway at the time.

Anyone else notice other skewed ship powers or other skyways where this is occurring?

Pirate Overlord
Mar 10, 2009
6079
I have noticed the sideways sirens attack only on the Armada ships in Hamamatsu skyway & My blue serpent does not show up at all but the damage does register. I did send in a bug report on it though. The attacks work normally on all other ships so far.

Lieutenant
Sep 17, 2011
160
I've seen it happen on my Marleybone Galleon while defeating Armada ships wherever they're found. I found it really funny that the powers were being used sideways. I haven't seen the other bug yet, but I can bet it's kinda annoying.

Ensign
Feb 16, 2010
25
Aha! A common thread, we too were fighting Armada ships in Marleybone when we noted the skewed powers.

Avast! The dastardly Armada is gaining ground seeking to turn the Spiral upside down. They must be stopped. To your ships mateys! Blast them out of the skys!

Pirate Overlord
Mar 10, 2009
6079
Kymma Starflower on Aug 13, 2013 wrote:
Aha! A common thread, we too were fighting Armada ships in Marleybone when we noted the skewed powers.

Avast! The dastardly Armada is gaining ground seeking to turn the Spiral upside down. They must be stopped. To your ships mateys! Blast them out of the skys!
Wow, I never thought about that. Good deduction on your part. Those sneaky clockworks


Ensign
Jun 04, 2009
5
I have the same problem so far only while fighting the Armada ships . My horn the great serpent doesn't show up. Just looks like my cannons are firing plain shot.Seems to work fine in other areas like the frog ships.