Ship equipment buttons grayed out

AuthorMessage
Ensign
Mar 06, 2012
1
I'm not sure where to post this. I have a Marleybonian heavy galleon and I am nautical level 61. Purchased the Marleybonia horn and a Cephalopod figurehead...I think both are crown shop items and either say 'any origin' or 'royal navy'. But they SHOULD work. They don't. The buttons for triggering them during naval combat are grayed out. I tried swapping them out for other gear to see if it was the item or the ship...nothing seems to work in those slots.

Any suggestions?

Commodore
Apr 28, 2012
938
When the game does not seem to be working correctly, the correct forum is the Bilge Pump.

The only time I've seen grayed out naval combat buttons is when my level was below the required level that the items needed to work. Do you have more than 1 Pirate? If so, maybe it was your other Pirate that was given the ship and tried to operate it.

Also, check the ship name again. I've never seen any ship named a Marleybonian Heavy Galleon. I think you are referring to a Royal Navy Galleon (Galleons are always heavy - it's a ship type). There also should be Nautical Level requirement for the ship although if you were below that level you never should have been able to equip it.

Also, look at the information about the Ship and the Ship items. There may be some other conditions that have to be met before it will work correctly.

Captain
Jul 16, 2014
670
Thanks Helpful Pirate!

Little Pirate,

What is your pirate level? And what are the exact names of your ship and the two items?

*Bonnie Anne, Your Pirate101 Community Manager*