Secret Tunnel Bug

Gunner's Mate
Sep 28, 2009
As I was promoting Bonnie Anne, I had finally gotten to the last part. First fight went fine, no problems. The fight with Captain Swing is where I encountered a bug. I had chosen the 2 companions to join me, El Toro and Flanders. Note, I am level 65 when this fight is happening. The first turn went fine. Then, my internet started acting up. It usually always does this every couple of hours or so which I have figured out was due to my ISP, ( Thanks Comcast for the "most reliable internet" ) so I had, as expected, disconnected from the game. Upon logging back in, I could not log into my Swashbuckler for about 15 minutes, I assumed it's because I was in an promotion quest area. After finally logging in, I come back to see all 3 of my companions had wounds, and that my health was at 1, which I guess meant the game had me lose the fight since I did not pick any actions for a turn.

I think if anyone were to disconnect from a battle in a promotion quest, they should automatically be sent back outside the entrance, as they are, more often than not, unable to log in as I've encountered this with a couple other promotion quest battles too.

Hello Gruesome Richard,

I hate to be the bearer of bad news, but this is not a bug. Unfortunately we have no way of telling when you disconnect purposefully or are disconnected through an unreliable Internet connection. Since players could force a disconnection state when they are losing in a fight to avoid companions being wounded, you will return to the game with wounded companions if this happens.

*One-Eyed Jack, Your Pirate101 Community Manager*