lost all progress

AuthorMessage
Petty Officer
Oct 11, 2012
63
I hope I am not repeating something but I could not find this in the message boards so I thought I should add it. I had 3 pirates on my account, 2 of them max, then i went 3 or so months without playing. When I tried to get back in through my account it said I had no pirates, it started me over. I had to start from scratch. I am not sure if it was because of all the changes or what but I just want to know if it had happened to someone else or if it was suppose to happen. Also, one of my friends that plays this game also lost his progress just like me. If anyone has had this happen to them or if anyone knows why it happened please send a reply.

Administrator
Oh oh! This definitely sounds concerning. I've forwarded your report to our Customer Service. You may want to contact them directly through the Customer Support form here.

*One-Eyed Jack, Your Pirate101 Community Manager*
Petty Officer
Oct 11, 2012
63
OK, thank you Jack, I sent them a email. I sure hope they can help I really hope I did not lose all that work.

Dread Pirate
Jun 17, 2013
2699
icewizard6589 on Jun 27, 2014 wrote:
OK, thank you Jack, I sent them a email. I sure hope they can help I really hope I did not lose all that work.
Hope you get those pirates back. That would be quite awful to lose all of that hard work and time that you put into them. Good luck and hope they show back up!

Petty Officer
Oct 11, 2012
63
I sent an email to customer service in king isle 2 weeks ago and they have not responded yet. How long do you think until they respond?