Game won't let me go to Achean Way Skyway

Jan 28, 2014
Ok, a couple minutes ago, I tried to enter the first skyway in Aquila when I was gonna build the mouse in Illios, but when I tried to enter, it wouldn't let me into the skyway no matter how long I waited. So I had to log out and back in. I can't join the game at first then I joined again. Tried it again, didn't work. Then I tried to teleport to a friend in that skyway but instead of the loading screen coming up, I was "Invisible" with my name tag still there. I couldn't move or anything, stuck again.

For some odd reason, the game is refusing me to go into the skyway for some odd reason. Any way this glitch/bug might happen?

EDIT: Looked at the rules, i'll fill this out.

Level of your character: 61
  • Location where the bug occurred: Anywhere at Achean Way Skyway.
  • Description of the bug: When I try to go to Achean Way Skyway, the game freezes no matter where I am, and no matter what I do to try to get in the skyway.
  • How often does this bug seem to happen? Every Time.
  • Were you playing Solo? Yes.
  • Were you the only one to experience this issue? Yes.
  • Can you reproduce this bug? Yes.

  • Bosun
    May 01, 2012
    The only thing I can think of is that you don't have the correct the Windstone to go to Aquila (check the Windstones that you have) or, if you play by purchasing chapters, that you haven't purchased the chapter for this account that allows you to go to Aquila. If you do have the correct Windstone and are a member (or have purchased the correct chapter), then I would contact support either using the Orange Question Mark above or by e-mailing them at Include your account name and Pirate name that you are having trouble with and specify what actions you have taken to get to this point. Good Luck.