Game ruining glitch

AuthorMessage
Captain
Dec 11, 2010
740
I just got a membership on here after so long to come across a glitch that utterly breaks the gameplay.
For one my ship doesnt show up in the skyway (same deal with enemy ships and player ships)
Two battles arent loading at all
and 3 I cant see enemies (So every once while I may bump into the 1st glitch )

Please The Friendly Necromancer (Or as they call ye over here, One eye Jack)
How can I fix this :( as I really dont want to lose my time on the one month membership for no gameplay

Pirate Overlord
Mar 10, 2009
6079
My guess would be your video driver might need updating. I would contact customer support (The orange question mark above) and send them a dxdiag file and they can tell you if anything in your system is needing help.

A DxDiag is a utility designed to display the specifications of the user's hardware, as well as to test DirectX software, including sound and video.

To create a dxdiag.txt just go to Start -> Run (or Search in Vista) and enterdxdiagand click OK. Once the program has run it's course, click "Save all Information" and it will output a txt file that you can attach to your submission.

Bosun
May 01, 2012
396
It would help if we had some more information like:
type of ship you are using
what world (Skull Island, Monquista, etc.) and what Skyway is this occurring in>
Does this happen on all worlds and Skyways?

Check to make sure that your computer meets the necessary requirements for playing the game.

Check to make sure that your computer has the latest updates for your Video Card.

Have you tried uninstalling and re-installing Pirate101?

If those don't help contact Support using the Help Menu above (The Orange Question Mark).

Administrator
Support has been notified of your situation and will be getting in touch with you over email.

*One-Eyed Jack, Your Pirate101 Community Manager*