Follow important game updates on Twitter @Pirate101 and @KI_Alerts, and Facebook!

Deteriorating stability and performance

AuthorMessage
Ensign
Apr 29, 2017
22
I have noticed over the last few weeks that the stability and performance of the game has reduced noticeably, with regular rubber banding, frozen screens and disconnects. I have noticed this happening to the pirates I play with as well, and my in game friends have reported similar issues.

Currently the performance of the game has reduced to a level where I no longer have any desire to play it, and have moved onto MMOs that should be far more demanding on my bandwidth and system, but run much more smoothly.

Whatever you have changed in recent weeks, please change it back.

Gunner's Mate
Sep 07, 2014
242
Here Here - myself and several of my mates have noticed that same problem.

oh and Hydra is still broken

Admiral
May 30, 2010
1168
Lots of dropped connections, no matter where I'm logged in (we've been traveling; I've tried to call up my pirates in hotels and on my in-laws' wifi). It has been twitchy and somewhat irritating to cope with.

Administrator
Sorry to hear about the stability and performance issues. We'll investigate a few things here on our end.

One question . . . If you play Wizard101 as well, are you also experiencing these issues when you play Wizard101, or only when you play Pirate101?

*One-Eyed Jack, Your Pirate101 Community Manager*
Pirate Overlord
Mar 16, 2012
9856
One-Eyed Jack on Jul 17, 2017 wrote:
Sorry to hear about the stability and performance issues. We'll investigate a few things here on our end.

One question . . . If you play Wizard101 as well, are you also experiencing these issues when you play Wizard101, or only when you play Pirate101?
I've noticed some issues with W101 mostly some lag; but its not as bad as P101.

Admiral
Oct 27, 2009
1432
Freezing on Wiz and disconnects on Pirate, while in the morph tent.

Admiral
Jun 02, 2013
1465
Being on the other side of the world I play the game at a time when there are less players on and I haven't experienced these issues even with a poor computer and internet.

Maybe Kingsisle currently can't handle an influx of players? I believe that the problem would be related to the amount of players on at one given time.

Gunner's Mate
Sep 07, 2014
242
Actually a number of us have wondered if Pirate had been shunted to a smaller server

Admiral
May 30, 2010
1168
One-Eyed Jack on Jul 17, 2017 wrote:
Sorry to hear about the stability and performance issues. We'll investigate a few things here on our end.

One question . . . If you play Wizard101 as well, are you also experiencing these issues when you play Wizard101, or only when you play Pirate101?
What I get in Wizard is an inability to target a spell every few rounds. It only lasts that round, but it's annoying, since opponents get a free attack in. It happened to me this morning, in fact.

Commodore
May 31, 2009
873
Pirate's definitely been stuttering more than usual for me lately, especially when I try to open my backpack, character page, companions, etc. or I move around for extended periods, and Wizard has been absolutely awful. I've had the "unable to target" glitch popping up and earlier this morning my laptop simply shut the game down while I was idling in Krokotopia. I'd left my character sitting to check my phone and suddenly the screen went black and my desktop popped back up. Seems like connection in both games is a bit unstable; I've had more problems this summer than in pretty much the whole time I've been playing.

Admiral
Oct 27, 2009
1432
Fiorenza Rosanante... on Jul 24, 2017 wrote:
What I get in Wizard is an inability to target a spell every few rounds. It only lasts that round, but it's annoying, since opponents get a free attack in. It happened to me this morning, in fact.
This is a known bug and they are working on a fix for it, possibly this week. It is triggered when there is a fight in a circle nearby to your fight. For some reason, one circle ending the card selection phase of the fight is affecting it in other battle circles. Only spells that must pick a target seem to be involved. Target everyone spells, like Frost Giant, Unicorn, and Bladestorm, or ones that can only be cast on oneself, like the "self heal only" Fairy or Moon school transform spells, and Star spells, like Fortify, seem to work fine even when the bug happens. So a quieter realm or using non targeting spells ought to help until they solve the bug.

Gunner's Mate
Sep 07, 2014
242
All fine and dandy but problems with wizard should - in my personal opinion be discussed on the wizard forum NOT on the pirate forum.

There has been no indication that any Fix for the pirate problem is being done.

Admiral
May 30, 2010
1168
Krigleblort on Jul 26, 2017 wrote:
All fine and dandy but problems with wizard should - in my personal opinion be discussed on the wizard forum NOT on the pirate forum.

There has been no indication that any Fix for the pirate problem is being done.
Most of us were responding to OEJ's question about whether we'd been seeing the same issues on Wizard as on Pirate. Calamity was very kindly explaining what caused the issue I'd mentioned.

Does anyone else get that funky lock-up on the cutscene when you're switching pirates? Doesn't always happen but it does occasionally, more often to Indigo than to me, even though we're using essentially identical computers.

Pirate Overlord
Mar 16, 2012
9856
Krigleblort on Jul 26, 2017 wrote:
All fine and dandy but problems with wizard should - in my personal opinion be discussed on the wizard forum NOT on the pirate forum.

There has been no indication that any Fix for the pirate problem is being done.
They first have to find what's causing the problem; if it's something they can fix from their end, then I'm sure something will be done. If, however, it's something from our end ( as in our computers unable to deal with a sudden influx of players causing problems with our computers ) - then nothing can be done, but we'll just have to wait out the problems until school starts in the Fall.

Captain
Apr 24, 2016
520
when me a friend were farming friar sand, I lagged so much in the corrupted shrine, I thought I would get pulled. it was on the way to the temple that the lag had happened.

Captain
Apr 24, 2016
520
i cannot even. my game was lagging SO FLIPPING BAD, I could not do anything. I would press the windows button, nothing happens, my game was stuck loading in mooshu, would not do anything. I had to turn the computer off all the way and then back on again. all I wanted to do, was go do the quests to get rooster cogburn. help! also sometimes when I wanna change pirates, my pirates wont load for like 1 to 2 minutes. I just wait the loading glitch out, but the lagging today was terrible