cant put anything on my ship

AuthorMessage
Ensign
Feb 11, 2016
1
i cant put any equipment on my ship even if it is origin ANY and natical level ANY it just shows me the red x that i cant use it plz help.

Captain
Sep 19, 2012
629
cooldeathx on Jan 21, 2018 wrote:
i cant put any equipment on my ship even if it is origin ANY and natical level ANY it just shows me the red x that i cant use it plz help.
welcome to the message boards and i sure hope this gets fixed soon.. can you give any more information? what ship you have.. anything? the devs will answer plus will give you a link to where to report the issue to get fixed soon.. however the more information you can give, the easier it will be to understand and fix.. good luck though <3

not to seem rude however here's an odd question, have you done Captain Avery quest to unlock being able to use ships in general? also was it a ship bought with gold, earned by quest or bought from crown shop? does your new ship match your character's level?

answering these types of questions can also help to scurry out any ornery little glitches that might be blocking your progress <3 but chin up I bet it will be solved quickly :3

stormy jen silver

Dread Pirate
May 27, 2009
1670
cooldeathx on Jan 21, 2018 wrote:
i cant put any equipment on my ship even if it is origin ANY and natical level ANY it just shows me the red x that i cant use it plz help.
Is it possible that you don't have your ship unbottled? If it doesn't have the little blue hand icon next to it, you need to equip it before you can... equip it.