Can not contact support? Help needed!

AuthorMessage
Ensign
Nov 11, 2008
24
Hi there.
Recently I have tried to contact support (both Wizard101 and Pirate101) using the address support@pirate101.com. It never fails whenever I email using this I get no response what-so-ever, not even the standard "Your message has been received..."
I also have tried accessing the contact support form located in the help pages, but instead of getting the nicely laid out form like others do, I get a link to help@kingsisle.com -- no form to fill out. (I also have tried the help@kingsisle.com email and never received a response either.)
Unless I am consistently being ignored, which I know is not typical, then I am having a problem. I have tried it using both Internet Explorer on my PC and also Safari on my tablet, both of which yield the same results. I'm not sure what else to do so I am hoping I can get some help here. While I am not having any huge need to contact support, it is pretty annoying to know I couldn't if I really needed to.
Thanks.

Pirate Overlord
Mar 10, 2009
6038
The Privateer on Jun 10, 2014 wrote:
Hi there.
Recently I have tried to contact support (both Wizard101 and Pirate101) using the address support@pirate101.com. It never fails whenever I email using this I get no response what-so-ever, not even the standard "Your message has been received..."
I also have tried accessing the contact support form located in the help pages, but instead of getting the nicely laid out form like others do, I get a link to help@kingsisle.com -- no form to fill out. (I also have tried the help@kingsisle.com email and never received a response either.)
Unless I am consistently being ignored, which I know is not typical, then I am having a problem. I have tried it using both Internet Explorer on my PC and also Safari on my tablet, both of which yield the same results. I'm not sure what else to do so I am hoping I can get some help here. While I am not having any huge need to contact support, it is pretty annoying to know I couldn't if I really needed to.
Thanks.
Hello Privateer, welcome to the message boards. Have you tried checking your Spam folder? If you do not have support saved as a contact, your email program may be kicking it out as spam.
The web issue may just be a tablet thing. I haven't used one yet but I hear horror stories from friends that tell me they do not act the same way as a computer does with navigating web pages.

Ensign
Nov 11, 2008
24
Chrissy Th'Blesser on Jun 10, 2014 wrote:
Hello Privateer, welcome to the message boards. Have you tried checking your Spam folder? If you do not have support saved as a contact, your email program may be kicking it out as spam.
The web issue may just be a tablet thing. I haven't used one yet but I hear horror stories from friends that tell me they do not act the same way as a computer does with navigating web pages.
Thanks for the reply!
Yes I did check my spam and no message was there (I have them as a contact.)
As for the issue with the website form, it also occurs on my computer, so I'm not sure if I have some security feature blocking it or what.

Administrator
The Privateer on Jun 10, 2014 wrote:
Hi there.
Recently I have tried to contact support (both Wizard101 and Pirate101) using the address support@pirate101.com. It never fails whenever I email using this I get no response what-so-ever, not even the standard "Your message has been received..."
I also have tried accessing the contact support form located in the help pages, but instead of getting the nicely laid out form like others do, I get a link to help@kingsisle.com -- no form to fill out. (I also have tried the help@kingsisle.com email and never received a response either.)
Unless I am consistently being ignored, which I know is not typical, then I am having a problem. I have tried it using both Internet Explorer on my PC and also Safari on my tablet, both of which yield the same results. I'm not sure what else to do so I am hoping I can get some help here. While I am not having any huge need to contact support, it is pretty annoying to know I couldn't if I really needed to.
Thanks.
Hi! I contacted our Customer Support and according to their records it appears the last ticket that was opened for your account was 140508-000606 on 5/27/2014 regarding Gardening in Wizard101.

If you're still having issues receiving our replies, they recommend going to your gmail junk box, which is a subfolder of the junk/spam folder labeled "6 more." Please look there and if you see messages from KingsIsle, mark them as "not spam."

I'll do some more asking around concerning your inability to view the help form. Have you tried using Chrome on your PC for submitting tickets?

Sorry for the inconvenience.

*One-Eyed Jack, Your Pirate101 Community Manager*
Ensign
Nov 11, 2008
24
One-Eyed Jack on Jun 11, 2014 wrote:
Hi! I contacted our Customer Support and according to their records it appears the last ticket that was opened for your account was 140508-000606 on 5/27/2014 regarding Gardening in Wizard101.

If you're still having issues receiving our replies, they recommend going to your gmail junk box, which is a subfolder of the junk/spam folder labeled "6 more." Please look there and if you see messages from KingsIsle, mark them as "not spam."

I'll do some more asking around concerning your inability to view the help form. Have you tried using Chrome on your PC for submitting tickets?

Sorry for the inconvenience.
Hi! Thanks for your reply. The form does show up in Chrome, like you suggested.
I did however check my spam box and I found no KingsIsle message. I have sent 3 or 4 emails since the one on 5/27, using the same email I always have, and yet I never get a reply. I'm definitely not blaming you guys, I don't even get the standard notification that my message has been received. So I'm not sure what is going on. I will try sending my message through the form and see if that helps.
Thanks.