The Item failed to redeem

AuthorMessage
Ensign
Oct 02, 2016
1
So on the Hoodoo bundle I bought it when it on a 25% sale and waited till today to try to open an item. When I tried to open any item it said The Item failed to redeem, when I opened a gifted Ashes of the Armada booster pack it redeemed but any of the Hoodoo bundle won't redeem.

I would like some help please and thank you

Petty Officer
Nov 22, 2010
83
Hey there, and welcome to the message boards. So this is a known problem, and the agreed upon strategy to fix it is to redeem before doing ANYTHING in game when you log in. Don't go to a different realm, instance, or world.

Matthew Walker

Moderator
This is a known glitch, but you should be able to get around it. Have you tried logging in and logging back out? That worked for me when I had the same problem with a different item.

~Virtuous Vanessa

The Untold Spiral Founder/Owner, Co-leader of Mercenaries101, MMORPG.com Writer, and much more!
~
_~ )_)_~
)_))_))_)
_!__!__!_
\______t/
~~~~~~~~~~~~~
Lieutenant
Sep 17, 2012
160
Logging out and back in seems to fix the problem for me; however, if it continues a quick email to customer support should fix the issue.

Admiral
Nov 23, 2011
1309
Most of the time simply going back to the character selection screen, then re-selecting your pirate, fixes it. I vaguely remember that once I had to fully exit and reload the game, but usually the return-to-character-selection trick works.

-Indigo